Skip to main content
CVE-2025-59471VulnerabilityPublished Updated

Bundesamt für Sicherheit in der Informationstechnik Red Hat · Vercel Next.js: Mehrere Schwachstellen ermöglichen Denial of Service

Affects Bundesamt für Sicherheit in der Informationstechnik Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-59471· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in Red Hat package updates : update Red Hat next.js when convenient.

Data as of 27 Oct 2026, 01:28 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 16.1.5, 15.5.10, 14.0 +4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
vercelnextAffected
  • >=16.0 <16.1.5
Fixed in
  • 16.1.5
vercelnextAffected
  • >=15.0 <15.5.10
Fixed in
  • 15.5.10
vercelnextAffected
  • >=14.0 <14.0
Fixed in
  • 14.0
vercelnextAffected
  • >=13.0 <13.0
Fixed in
  • 13.0
vercelnextAffected
  • >=12.0 <12.0
Fixed in
  • 12.0
vercelnextAffected
  • >=11.0 <11.0
Fixed in
  • 11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version, Red Hat Streams for Apache Kafka 3.2.0, is available and includes patches for these vulnerabilities. Users should upgrade to this version after ensuring all previously released errata relevant to their system have been applied. Detailed update instructions are available from Red Hat's customer portal. No additional mitigation steps are indicated beyond applying the official update.

Description

Multiple vulnerabilities affecting Next.js components used in Red Hat Streams for Apache Kafka 3.2.0 can lead to denial of service conditions. These issues include denial of service via specially crafted HTTP requests targeting React Server Components. The vulnerabilities are part of a broader set of security fixes in Red Hat Streams for Apache Kafka 3.2.0, which addresses various security and bug issues across components including Next.js, Netty, Axios, lodash, and others.

References

Community reviews

Loading reviews…