poetry · virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2.5.1_2 soon.
Data as of 30 Oct 2026, 08:16 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 7.1 |
|---|
- Patch
- Available – fixed in 2.5.1_2
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade poetry to 2.5.1_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in virtualenv version 2.5.1_2 that restores proper escaping of the prompt value in the bash activator script. Users should upgrade to this version or later to remediate the vulnerability. Until patched, avoid activating virtual environments created with affected versions if the --prompt value is untrusted or potentially attacker-controlled.
Description
A vulnerability in the bash activator script of virtualenv allows an attacker controlling the --prompt value to execute arbitrary commands. This occurs because the prompt value is inserted unescaped into the PS1 variable when the bash shell option promptvars is off, but can be re-enabled later, causing command substitution to run. This regression was introduced in virtualenv 21.14.9 and persists through 21.14.12. The issue affects activation scripts, specifically bash's bin/activate, and can lead to command execution as the user activating the environment.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-cx6f-vjhg-g3cc (opens in a new tab)
- github.com/pypa/virtualenv/pull/3466 (opens in a new tab)
- github.com/pypa/virtualenv/commit/3598e201f6f044e389136b2347a8a919ac03c5f4 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.13 (opens in a new tab)