Skip to main content
VulnerabilityPublished

CVE-2026-113723: virtualenv · Bash prompt values can change meaning under older compatibility modes

Affects poetrySource GCVE Database

0
Compare
Authoritative record:CVE-2026-113723· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 2.5.1_1 or 1.2.2_1 soon.

Data as of 30 Oct 2026, 08:17 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.07.1
Patch
Available – fixed in 2.5.1_1, 1.2.2_1
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 2.5.1_1 or 1.2.2_1.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=1.1.0 <1.2.2_1
  • >=1.8.0 <2.5.1_1
Fixed in
  • 1.2.2_1
  • 2.5.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in virtualenv versions 1.2.2_1 and 2.5.1_1 and later. Users should upgrade to these fixed versions to remediate the issue. The vendor advisory confirms the fix in 21.14.8 (corresponding to these versions). No additional mitigation is required if patched. Until patched, avoid activating virtualenv environments with attacker-controlled prompt values in affected shell configurations.

Description

CVE-2026-113723 is a vulnerability in virtualenv's bash activation prompt handling where attacker-controlled prompt text can be interpreted as executable shell syntax under certain older bash compatibility modes (4.2 and below) or when using dash shell. This occurs because the prompt string assigned to PS1 is expanded twice, allowing command execution when the prompt is drawn. The issue affects POSIX activation scripts and arises if an attacker can supply the prompt value and a user activates the environment in an affected shell configuration.

References

Community reviews

Loading reviews…