CVE-2026-113724: virtualenv · Deletion recovery can change a symlink target's mode
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 4.5 Medium : upgrade to 2.5.1_1 when convenient.
Data as of 30 Oct 2026, 08:17 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 4.5 |
|---|
- Patch
- Available – fixed in 2.5.1_1
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade poetry to 2.5.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in virtualenv version 2.5.1_1. Users should upgrade to this version or later to avoid the issue. The fix avoids changing POSIX mode bits on deletion failure and properly handles Windows read-only entries without following symlinks.
Description
A vulnerability in virtualenv's deletion error handler can cause unintended permission changes on symlink targets. When a deletion fails on a symbolic link inside a read-only directory, the handler uses lstat() to get mode bits but applies them with chmod(), which follows the symlink. This can change the target's permissions to 0777 if the target is owned by the invoking user and initially not writable. The issue affects virtualenv versions from 2.4.2 up to but not including 2.5.1_1. A fix is available in version 2.5.1_1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-43mp-35q3-x3fq (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113724 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3427 (opens in a new tab)
- github.com/pypa/virtualenv/commit/2bfdc0230d1b2685fedfcfe66c835b9a2ec7c440 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)