Skip to main content
VulnerabilityPublished

CVE-2026-113722: virtualenv · Generated POSIX console launchers interpret destination paths as shell syntax

Affects poetrySource GCVE Database

0
Compare
Authoritative record:CVE-2026-113722· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 2.5.1_1 or 1.2.2_1 soon.

Data as of 30 Oct 2026, 08:17 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
Patch
Available – fixed in 2.5.1_1, 1.2.2_1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 2.5.1_1 or 1.2.2_1.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=1.1.0 <1.2.2_1
  • >=1.8.0 <2.5.1_1
Fixed in
  • 1.2.2_1
  • 2.5.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in virtualenv versions 2.5.1_1 and 1.2.2_1 that properly quotes the interpreter path to prevent shell expansion. Users should upgrade to these fixed versions or later. Until then, avoid running POSIX console launchers generated by virtualenv or pip in environments where the destination path could be attacker-controlled.

Description

A vulnerability in virtualenv's POSIX console launcher generation allows attacker-controlled destination paths to be interpreted as shell syntax. This occurs because the interpreter path is not properly escaped in the shell wrapper, enabling shell command injection when running generated launchers. The issue affects POSIX console scripts created by virtualenv's app-data seeder or pip when a shell wrapper is required. Windows executable launchers are not affected. Exploitation requires an attacker to influence the environment destination path and the user to run the generated launcher, resulting in execution of arbitrary shell commands with the user's privileges.

References

Community reviews

Loading reviews…