Skip to main content
VulnerabilityPublished

CVE-2026-113722: virtualenv · Generated POSIX console launchers interpret destination paths as shell syntax

Affects virtualenvSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113722· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 21.14.9 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 21.14.9
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenv to 21.14.9.

Affected software

ProductAffectedFixed in
Bitnamivirtualenvpkg:bitnami/virtualenvOther threatsAffected
  • <21.14.9
Fixed in
  • 21.14.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade virtualenv to version 21.14.9 or later, which contains the fix for this vulnerability. After upgrading, regenerate all existing POSIX console launchers to ensure they are not vulnerable. No other specific mitigations are indicated.

Description

virtualenv versions prior to 21.14.9 generate POSIX console launchers that improperly quote interpreter paths. This flaw allows command substitution and backtick expansion in the generated /bin/sh wrapper script if the interpreter path contains spaces or results in a shebang longer than 127 bytes. An attacker who can influence the environment destination can execute arbitrary commands with the user's privileges when the generated launcher is run. Existing launchers are not fixed by upgrading virtualenv alone and must be regenerated. The issue is fixed in version 21.14.9.

References

Community reviews

Loading reviews…