Skip to main content
VulnerabilityPublished

CVE-2026-113720: virtualenv · Seeded files retain permissions from an older cache

Affects poetrySource GCVE Database

0
Compare
Authoritative record:CVE-2026-113720· Medium 4.4

Not known to be exploited · CVSS 4.4 Medium : upgrade to 2.5.1_1 or 1.2.2_1 when convenient.

Data as of 30 Oct 2026, 08:29 UTC

CVSS 4.0 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.5.1_1, 1.2.2_1
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 2.5.1_1 or 1.2.2_1.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=1.1.0 <1.2.2_1
  • >=1.8.0 <2.5.1_1
Fixed in
  • 1.2.2_1
  • 2.5.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in virtualenv versions 1.2.2_1 and 2.5.1_1, which enforce stricter file permissions on files copied from the app-data cache, respecting the current umask. Users should upgrade to these fixed versions to remediate the issue. No additional mitigation is required if the environment is updated. If upgrading is not immediately possible, ensure that the cache is not populated with permissive permissions and restrict access to the environment directories to prevent traversal by other local users.

Description

Virtualenv versions prior to 1.2.2_1 and 2.5.1_1 have a vulnerability where files copied from a cached app-data directory retain file permissions from the cache rather than applying the current environment's umask. This can result in files with overly permissive access rights in new environments if the cache was created with a permissive umask, potentially allowing other local users to modify files such as pip scripts. The issue arises because shutil.copy preserves the source file mode, overriding the current umask. A fix is available in versions 1.2.2_1 and 2.5.1_1, which enforce stricter file permissions when copying from the cache.

References

Community reviews

Loading reviews…