Skip to main content
VulnerabilityPublished

CVE-2026-113718: virtualenv · Xonsh activation literals depend on the script decoding codec

Affects virtualenvSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113718· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 21.14.9 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.07.1
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 21.14.9
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenv to 21.14.9.

Affected software

ProductAffectedFixed in
Bitnamivirtualenvpkg:bitnami/virtualenvOther threatsAffected
  • <21.14.9
Fixed in
  • 21.14.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade virtualenv to version 21.14.9 or later, where this issue is fixed. No other mitigation is required as the fix addresses the root cause.

Description

A vulnerability in virtualenv prior to version 21.14.9 affects the POSIX xonsh activation script generation. When using legacy multibyte codecs like GBK or Big5, the UTF-8 encoded activate.xsh script can be misinterpreted, allowing an attacker to inject and execute arbitrary statements when the script is sourced. This issue is resolved in version 21.14.9.

References

Community reviews

Loading reviews…