Skip to main content
CVE-2026-115915VulnerabilityPublished Updated

Vllm: Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data))

Affects vllmSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-115915· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 0.32.0 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.18.1
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vllm to 0.32.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • >=0.30.0 <0.32.0
  • =0.30.0
  • =0.31.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vLLM to version 0.32.0 or later, where this issue is fixed. Ensure that dependent components such as Ghostscript and Pillow are also updated to non-vulnerable versions to fully mitigate the associated risks.

Description

vLLM versions prior to 0.32.0 contain a critical vulnerability where attacker-controlled image bytes are passed to Pillow's Image.open without restricting decoder selection. This allows dispatching of malicious EPS payloads that can lead to command execution if the host has a vulnerable Ghostscript (CVE-2024-29510) or denial of service via Pillow vulnerabilities (CVE-2026-59203). The issue is fixed in version 0.32.0.

References

Community reviews

Loading reviews…