Skip to main content
CVE-2026-116178VulnerabilityPublished Updated

vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the

Affects vllmSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116178· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 0.30.0 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.2
CNA (VulnCheck)CVSS 3.15.9
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.30.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vllm to 0.30.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • 0.20.0 – 0.29.0
  • >=0.20.0 <0.30.0
15 affected builds
Fixed in
  • 0.30.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vLLM to version 0.30.0 or later, where this vulnerability is fixed. No other mitigation is required as the patch fully addresses the issue.

Description

vLLM versions from 0.20.0 up to but not including 0.30.0 contain a denial of service vulnerability. Remote attackers can crash the engine by sending malformed multimodal metadata to the /inference/v1/generate endpoint. This causes a negative text span in Qwen2.5-VL position construction, terminating the engine. The issue is fixed in version 0.30.0.

References

Community reviews

Loading reviews…