vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force
Affects vllmSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 0.24.0 soon.
Data as of 29 Oct 2026, 14:41 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.2 |
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade vllm to 0.24.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading vLLM to version 0.24.0 or later. No other mitigation or temporary workaround is indicated by the vendor advisory. Applying the official fix fully remediates the vulnerability.
Description
vLLM versions from 0.9.2 up to but not including 0.24.0 contain a server-side request forgery (SSRF) vulnerability. This flaw allows API callers to embed a decoded address in the X-Request-Id header, forcing outbound connections. Exploitation can cause a P2pNcclConnector prefill worker to connect to an attacker-controlled host, potentially leaking NCCL unique_id and KV-cache tensors or blocking the worker. The vulnerability is rated high severity with a CVSS score of 8.2. A fix is available in version 0.24.0.