Skip to main content
CVE-2026-116173VulnerabilityPublished Updated

vLLM from 0.22.0 before 0.24.0 contains a denial of service vulnerability that allows remote attackers to terminate

Affects vllmSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116173· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 0.24.0 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.2
CNA (VulnCheck)CVSS 3.15.9
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vllm to 0.24.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • >=0.22.0 <0.24.0
  • =0.22.0
  • =0.22.1
  • =0.23.0
Fixed in
  • 0.24.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected vLLM installations to version 0.24.0 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended mitigation.

Description

vLLM versions from 0.22.0 up to but not including 0.24.0 contain a denial of service vulnerability. Remote attackers can exploit this flaw by sending specially crafted Generate or GenerateStream requests with output_logprobs enabled and more than 128 output_candidates.token_ids. This triggers a fatal sampler exception in the Rust gRPC frontend, causing the EngineCore to crash and resulting in denial of service. The issue is fixed in version 0.24.0.

References

Community reviews

Loading reviews…