Skip to main content
CVE-2026-116177VulnerabilityPublished Updated

vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated

Affects vllmSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116177· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 0.25.0 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.25.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vllm to 0.25.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • 0.10.2 – 0.24.0
  • >=0.10.2 <0.25.0
25 affected builds
Fixed in
  • 0.25.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vLLM to version 0.25.0 or later, where this vulnerability is fixed. The vendor advisory confirms a patch is available. No other mitigations are specified.

Description

vLLM versions from 0.10.2 up to but not including 0.25.0 contain a vulnerability where unauthenticated attackers can cause uncontrolled memory consumption by submitting specially crafted decompression-bomb images. This leads to out-of-memory (OOM) conditions that kill worker processes and cause denial of service. The issue arises because the Nemotron-VL processors globally set Image.MAX_IMAGE_PIXELS to None, disabling limits on image decompression size. A fix is available in version 0.25.0.

References

Community reviews

Loading reviews…