CVE-2026-115917: Vllm · Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with
Affects vllmSource GCVE Database
Not known to be exploited · CVSS 3.4 Low : upgrade to 0.32.0 when convenient.
Data as of 29 Oct 2026, 14:41 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 3.4 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade vllm to 0.32.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vLLM to version 0.32.0 or later, where the CORSMiddleware configuration no longer allows wildcard origins by default. This official fix addresses the misconfiguration and mitigates the risk. No additional mitigation is required if the upgrade is applied.
Description
vLLM versions prior to 0.32.0 have a misconfiguration in the OpenAI-compatible server where Starlette CORSMiddleware allows all origins by default. This allows a malicious web page to make cross-origin requests from a victim's browser to an unauthenticated vLLM server on localhost, internal networks, or VPNs, potentially consuming GPU resources and reading responses. The vulnerability does not enable cookie-based CSRF attacks as credentials are disabled by default, and bearer token authentication limits exposure to already authorized callers. The issue is fixed in version 0.32.0.
References
- github.com/vllm-project/vllm/releases/tag/v0.32.0 (opens in a new tab)
- github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa (opens in a new tab)
- github.com/vllm-project/vllm/pull/61009 (opens in a new tab)
- github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh (opens in a new tab)