Skip to main content
CVE-2026-115918VulnerabilityPublished Updated

Vllm: From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an

Affects vllmSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115918· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.32.0 when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.5
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vllm to 0.32.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • 0.16.0 – 0.31.0
  • >=0.16.0 <0.32.0
24 affected builds
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in vLLM version 0.32.0 that fixes this vulnerability. Users should upgrade to version 0.32.0 or later to remediate this issue. No additional mitigations are specified or required once patched.

Description

vLLM versions from 0.16.0 up to but not including 0.32.0 contain a vulnerability in the /v1/responses endpoint. An authenticated user can supply a crafted template in chat_template_kwargs[chat_template] when no server template is configured. This bypasses the intended trust policy and may cause CPU or memory exhaustion due to Jinja template rendering. The issue is resolved in version 0.32.0.

References

Community reviews

Loading reviews…