Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and drivers. These flaws could potentially be exploited by an attacker to compromise the system. The issues impact numerous components including architectures (ARM64, x86), various drivers, filesystems, networking protocols, and kernel subsystems. A security update correcting these flaws is available and requires a system reboot and recompilation of third-party kernel modules due to an ABI change.
Multiple vulnerabilities in ImageMagick affect various Ubuntu releases, including 14.04 LTS and 25.10. These vulnerabilities arise from improper handling of malformed image files, potentially allowing attackers to cause denial of service or execute arbitrary code if a specially crafted image is processed. Fixes have been released for affected versions.
Multiple vulnerabilities were discovered in OpenEXR affecting Ubuntu LTS releases. These include incorrect handling of sample count accumulation in deep scan line image files (CVE-2026-27622), an integer overflow in the PXR24 decoder (CVE-2026-34380), and a signed integer overflow in the PIZ decoder (CVE-2026-34588). Exploitation of these issues could lead to denial of service or arbitrary code execution. The vulnerabilities specifically affect Ubuntu 16.04 through 26.04 LTS versions of OpenEXR. Fixes are available through Ubuntu Pro Extended Security Maintenance (ESM) packages.
A vulnerability in the wheel package was discovered where it did not correctly handle certain file paths. If a user or automated system opened a specially crafted file, an attacker could potentially execute arbitrary code or cause the program to crash. This issue affects specific versions of the wheel package on Ubuntu 24.04 LTS. A fix is available through an update to version 0.42.0-2ubuntu0.1~esm1.
Multiple vulnerabilities were discovered in the AppArmor Linux kernel Security Module (LSM) and various Linux kernel subsystems affecting the linux-azure-fips package. These vulnerabilities could allow an unprivileged local attacker to load, replace, or remove arbitrary AppArmor profiles, potentially causing denial of service, exposure of sensitive kernel memory, local privilege escalation, or container escape. The issues affect numerous kernel subsystems and architectures. A security update fixing these vulnerabilities is available in linux-azure-fips version 6.8.0-1052.58+fips1.
A vulnerability in the Ruby URI gem affects multiple Ruby versions, where sensitive information may be improperly handled when combining URIs. This flaw could allow a remote attacker to leak authentication credentials. The issue is addressed by updates provided by Ubuntu for affected Ruby packages across several LTS releases and newer versions.
Multiple vulnerabilities were discovered in the linux-azure-6.8 kernel, including issues in the AppArmor Linux kernel Security Module that allow unprivileged local attackers to manipulate AppArmor profiles, potentially causing denial of service, information exposure, local privilege escalation, or container escape. Additionally, improper CPU cache initialization could allow a local attacker with hypervisor access to overwrite SEV-SNP guest memory, leading to data integrity loss. Some AMD processors may leak privileged information due to data inference from previous stores. Numerous other security flaws were identified across many Linux kernel subsystems and architectures.
A vulnerability in libssh was discovered where improper bounds checking during SFTP extension processing could cause client applications to crash or behave unexpectedly, leading to denial of service. This issue affects certain versions of libssh on Ubuntu 26.04 LTS. A fix is available in version 0.11.3-1ubuntu2.