Multiple security vulnerabilities were identified in the Linux kernel real-time version 6.8, affecting several subsystems including Ext4, packet sockets, network traffic control, TLS protocol, VMware vSockets driver, and XFRM. These flaws could potentially allow an attacker to compromise the system. Fixes have been released in versions 6.8.1-1035.36 and 6.8.1-1035.36~22.04.1. Users are advised to update and reboot their systems to apply these patches. Due to ABI changes, recompilation of third-party kernel modules may be required.
Multiple security vulnerabilities were identified in the Linux kernel affecting various subsystems including Ext4 file system, NFS server daemon, packet sockets, network traffic control, and VMware vSockets driver. These flaws could potentially allow an attacker to compromise the system. Fixes have been released for affected Ubuntu kernel packages, and users are advised to update and reboot their systems. Due to ABI changes, recompilation of third-party kernel modules may be necessary after updating.
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems affecting numerous subsystems including architectures, drivers, networking, and core kernel components. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues has been released and requires a system reboot and recompilation of third-party kernel modules due to ABI changes.
Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures including ARM32, ARM64, x86, various device drivers, networking components, and file systems. These flaws could potentially allow an attacker to compromise the affected system. Updates correcting these issues have been released for the linux-ibm-6.8 kernel packages. Users should apply the updates and reboot to ensure the fixes take effect.
CVE-2024-40915 concerns a vulnerability in the Microsoft product related to the riscv architecture, specifically involving the __kernel_map_pages() function. The issue involves sleeping in an invalid context, which is a concurrency or synchronization flaw. The affected version is exactly version 2.0. No CVSS score or detailed impact information is provided.
Multiple security vulnerabilities were identified in the Linux kernel used in the linux-azure, linux-azure-5.15, and linux-azure-fips packages. These flaws affect the NTFS3 file system and network traffic control subsystems and could potentially allow an attacker to compromise the system. Fixes for these issues have been released and are available in updated kernel versions. Users must apply the updates and reboot to ensure protection. Due to ABI changes, recompilation of third-party kernel modules is required after updating.
CVE-2025-4435 is a vulnerability in Microsoft software versions 2.0 and 3.0 where the Tarfile component extracts filtered members when errorlevel=0. This issue relates to improper handling of error conditions during archive extraction.
Eventlet versions prior to 0.40.3 contain a vulnerability in the WSGI parser that allows HTTP request smuggling via improper handling of HTTP trailer sections. This flaw can enable attackers to bypass front-end security controls, launch targeted attacks against users, and poison web caches. The issue is fixed in version 0.40.3 by dropping trailers, which may break setups relying on trailers. Avoid exposing eventlet.wsgi to untrusted clients as a workaround.