A directory traversal vulnerability (CVE-2025-67030) exists in the extractFile method of the plexus-utils component used by Maven. This vulnerability could allow an attacker to write files outside the intended directory during extraction. Red Hat has issued a security update for Maven 3.9 in Red Hat Enterprise Linux 9.6 Extended Update Support to address this issue.
A stack buffer overflow vulnerability exists in GIMP's PNM file format parser due to an off-by-one error in the pnmscanner_gettoken() function. This flaw can cause memory corruption when processing specially crafted PNM files, potentially leading to denial of service or arbitrary code execution. The issue has been assigned CVE-2026-58380 with a CVSS score of 7.3 (high severity). Red Hat has released patches for affected versions of GIMP in Red Hat Enterprise Linux 9.
A heap buffer overflow vulnerability exists in GIMP's Paint Shop Pro (PSP) file format parser due to incorrect buffer size calculations when processing low bit-depth images. This flaw allows a remote attacker to cause arbitrary code execution or denial of service by tricking a user into opening a specially crafted PSP image file. The issue is tracked as CVE-2026-58379 with a CVSS score of 7.3 (high severity). Red Hat has released security updates addressing this vulnerability in GIMP packages for Red Hat Enterprise Linux 9.
CVE-2026-14330 is a vulnerability involving multiple unbounded alloca() calls in the PulseAudio protocol server component of PipeWire, a multimedia server for Linux. This flaw can lead to a stack overflow condition. The vulnerability has a CVSS score of 5.5 (medium severity) and impacts availability but not confidentiality or integrity. Red Hat has issued a security advisory with an update for PipeWire in Red Hat Enterprise Linux 9 to address this issue.
A heap use-after-free vulnerability exists in the libblkid library of util-linux during nested partition probing. This flaw occurs because certain partition probers cache raw pointers that become stale after array reallocations, leading to potential memory corruption. An attacker can exploit this by presenting a crafted block device image, triggering the flaw automatically via udev/udisks without user interaction. The impact includes limited information disclosure or denial of service. Red Hat has released patches to address this issue in their util-linux packages.
A security vulnerability (CVE-2026-9256) affecting the ngx_http_rewrite_module of nginx in Red Hat Enterprise Linux 10 allows for potential code execution and denial of service. Red Hat has issued an important security advisory with an update to address this issue. The vulnerability impacts multiple architectures and product variants of Red Hat Enterprise Linux 10 and related CodeReady Linux Builder packages. The advisory references a fix available in updated nginx packages.
A heap-use-after-free vulnerability exists in libxslt's handling of attribute metadata during processing of result tree fragments. This flaw can cause memory corruption and application crashes due to improper cleanup of ID attributes. It affects Red Hat Hardened Images RPMs including libxml2 packages. No patch or mitigation meeting Red Hat's criteria is currently available.
A vulnerability in MariaDB's mariadb-dump utility allows remote attackers to execute arbitrary code due to improper validation of user-supplied paths. Exploitation requires user interaction with the mariadb-dump utility. Successful exploitation could lead to arbitrary code execution with the privileges of the current user. No patch or mitigation meeting Red Hat's criteria is currently available.
A high-severity heap buffer overflow vulnerability (CVE-2026-4177) exists in the perl-YAML-Syck module versions through 1.36. This module provides a Perl interface to the libsyck data serialization library, enabling conversion between Perl data structures and YAML strings. The vulnerability affects the YAML emitter component and could lead to memory corruption.
A security advisory from Red Hat addresses vulnerabilities in Red Hat Hardened Images RPMs, specifically in curl and libcurl packages. One notable issue (CVE-2026-3783) involves the potential leakage of OAuth2 bearer tokens during HTTP(S) redirects when curl follows redirects and .netrc files contain entries for the redirected host. This could lead to unauthorized disclosure of sensitive tokens. The advisory provides updated RPM packages to fix these issues.