CVE-2026-92194 is a high-severity vulnerability in Quest Foglight for Databases involving a directory traversal flaw in the loadManageServerLicense script. This flaw allows authenticated remote attackers to execute arbitrary code with SYSTEM privileges by exploiting improper validation of user-supplied paths in file operations.
CVE-2026-92197 is a high-severity vulnerability in Quest Foglight for Databases involving a directory traversal flaw in the unzipFile method. This flaw allows authenticated remote attackers to execute arbitrary code with SYSTEM privileges by exploiting improper validation of user-supplied file paths.
CVE-2026-92200 is a local privilege escalation vulnerability in Quest Foglight for Databases caused by incorrect permission assignment on a folder used by the product installer. An attacker with the ability to execute low-privileged code locally can exploit this flaw to escalate privileges and execute arbitrary code with SYSTEM-level permissions.
CVE-2026-92193 is a medium severity vulnerability in Quest Foglight for Databases affecting the FileServlet component. It allows authenticated remote attackers to disclose sensitive file path information due to improper validation of user-supplied paths. This flaw can lead to information disclosure with SYSTEM-level context.
CVE-2026-92199 is a local privilege escalation vulnerability in Quest Foglight for Databases caused by a hard-coded cryptographic key in the symmetricDecrypt method. An attacker with low-privileged code execution can exploit this flaw to escalate privileges to SYSTEM level and execute arbitrary code. The vulnerability has a high CVSS score of 7.8, indicating significant impact on confidentiality, integrity, and availability.
CVE-2026-92185 is an XML External Entity (XXE) vulnerability in Quest Foglight for Databases affecting the AbstractParser class. It allows remote attackers to disclose sensitive information without authentication by exploiting improper restriction of XML external entity references. The vulnerability can lead to information disclosure with SYSTEM-level context.
CVE-2026-92187 is a high-severity vulnerability in Quest Foglight for Databases involving a directory traversal flaw in the extractAndCreateUploadInfoList method. This flaw allows authenticated remote attackers to execute arbitrary code with SYSTEM privileges by exploiting improper validation of user-supplied file paths.
CVE-2026-92188 is a critical remote code execution vulnerability in Quest Foglight for Databases. It affects the ForgeMBeanServerSupport module, which lacks authentication controls. This allows unauthenticated remote attackers to execute arbitrary code with SYSTEM privileges on affected installations.
CGI versions for Perl prior to 5.00 contain a vulnerability that allows HTML injection when text containing the sequence '-->' is included in comments. This occurs because arguments are placed between <!-- and --> without proper escaping, allowing an attacker to prematurely close the comment and inject HTML content into the page.
A security flaw in InfiniFlow RAGFlow up to versions 0.27.2 and 1.0.0-rc2 affects the RunSQL function in the internal/engine/infinity/sql.go file. The vulnerability involves manipulation of the tableName/kbIDs arguments, leading to an authorization bypass. This flaw can be exploited remotely. Public exploit code has been released. The CVSS score is 4.3, indicating a medium severity impact.
A denial of service vulnerability exists in Perl CGI versions from 4.71 before 5.00. The issue arises because the uploadInfo function dereferences its argument and calls its filename method without verifying that the argument is an upload filehandle. If a plain string referencing a defined global variable is passed, it is treated as a symbolic reference, causing the method call to fail and resulting in a denial of service.
A weakness in spatie url-signer versions up to 2.1.3 affects the AbstractUrlSigner::validate function due to incorrect type conversion caused by manipulation of the expires argument. This vulnerability can be exploited remotely and has publicly available exploit code. Upgrading to version 2.1.4 addresses the issue.
CGI versions before 5.00 for Perl have a vulnerability that allows HTTP header injection. This occurs because the header decoding process decodes HTML entities after the newline check, allowing encoded carriage return or line feed characters to reach the response. Additionally, multipart_start and do_push functions do not properly validate header values or types, enabling attackers to inject headers or split HTTP responses when request data is passed into these header values.
A vulnerability in Sanluan PublicCMS 5 affects the TradePaymentService.pendingRefund function, allowing remote attackers to bypass authorization by manipulating the userId argument. The vulnerable web trade payment controller was removed starting with the 202608 series. Exploit code is publicly available. The vulnerability has a medium severity rating with a CVSS score of 6.3.
CGI versions for Perl prior to 5.00 have a vulnerability where certain request-derived values are returned untainted under Perl's taint mode. This includes upload filenames, uploadInfo values, some path_info and script_name values, Accept headers, and certain cookie values. These values bypass taint checks because they originate from regex captures or hash keys, which Perl does not mark as tainted, potentially allowing unvalidated data to be used in security-sensitive contexts.
CGI::Cookie versions before 5.00 for Perl contain a vulnerability where cookie attribute injection is possible via unvalidated path, domain, and expires values. These values are inserted into the Set-Cookie header without validation for semicolons or control characters, allowing an attacker controlling these inputs to inject additional cookie attributes such as Domain or SameSite.
CGI versions before 5.00 for Perl contain a vulnerability where an infinite loop can occur on processing a short request body if $DISABLE_UPLOADS is set. This happens because the code reads until the Content-Length bytes have arrived, but if the actual body is shorter, the read returns 0 repeatedly, causing the loop to never end. This allows a client to keep a server process busy indefinitely with a crafted request.
CVE-2026-92189 is a critical remote code execution vulnerability in Quest Foglight for Databases. It arises from improper validation of user-supplied file paths in the writeTopologySectionToFile method, allowing unauthenticated remote attackers to execute arbitrary code with SYSTEM privileges.
CGI versions from 4.62 up to but not including 5.00 for Perl contain a cross-site scripting (XSS) vulnerability. This occurs because URLs returned by the url and self_url methods pass through URI's canonical method, which leaves apostrophes in the path raw and decodes %27 in query parameters. If an application inserts these URLs into single-quoted HTML attributes or JavaScript strings, it may be vulnerable to XSS attacks.
CGI versions prior to 5.00 for Perl contain a denial of service vulnerability. This occurs when submitted values are used as regular expressions for optgroup selection in the scrolling_list function without proper escaping. Malicious input can cause the process to crash or become unresponsive due to heavy regex backtracking.