CVE-2026-57565 is a path traversal vulnerability in the Readest ebook reader prior to version 0.11.10. The flaw allows an authenticated attacker to craft a file name that includes path traversal sequences, enabling them to overwrite or poison another user's stored book object and corrupt associated metadata. This occurs due to improper validation of file names and URL normalization in the R2 backend. The issue is fixed in version 0.11.10.
CVE-2026-122019 is an authorization bypass vulnerability in 6amTech 6valley version 16.0. It affects the existingAccountCheck function in the /api/v1/auth/existing-account-check endpoint within the Social Login Flow component. The vulnerability arises from manipulation of the user_response argument, allowing an attacker to bypass authorization remotely. Public exploit code is available for this vulnerability.
CVE-2026-57566 is a critical server-side request forgery (SSRF) vulnerability in readest versions prior to 0.11.10. The unauthenticated /api/opds/proxy route allowed attackers to supply arbitrary URLs that the server would fetch without proper restrictions or validation. This enabled attackers to use the service as an open proxy to access internal network resources, including cloud metadata services on self-hosted deployments. Cloudflare Workers deployments mitigate internal network impact by restricting access to private and link-local addresses, but the fetch-and-reflect behavior remains unauthenticated. The issue is fixed in version 0.11.10.
Improper isolation of shared resources in aws-network-policy-agent in Amazon EKS Network Policy Agent before 1.3.7 (VPC CNI before 1.22.3) might allow an authenticated adjacent user to bypass NetworkPolicy ingress enforcement on co-located pods via eBPF conntrack map poisoning using crafted AF_PACKET frames.
To remediate this issue, users should upgrade to Amazon VPC CNI Managed Add-on v1.22.3 or later (which includes Network Policy Agent v1.3.7).
CVE-2026-57567 is a path traversal vulnerability in the readest ebook reader affecting desktop Tauri builds prior to version 0.11.10. The flaw allows JavaScript running in the privileged application origin to read or write arbitrary files on the filesystem by exploiting insufficient validation of file paths in the download_file and upload_file commands. This can lead to exposure of sensitive data such as keys and tokens, or overwriting of trusted files. The issue is fixed in readest version 0.11.10.
CVE-2026-115473 is an out-of-bounds read vulnerability in the cesanta mongoose embedded web server and network library. Versions prior to 7.22 improperly read bytes from path buffers without verifying sufficient length, leading to one-byte heap out-of-bounds reads. This can be triggered by unauthenticated remote requests to specific HTTP handlers with crafted short paths. On systems without memory protection, this could expose adjacent memory bytes or affect path acceptance, and instrumented builds may crash. The issue is fixed in version 7.22.
CVE-2026-55367 is a resource exhaustion vulnerability in the h2o HTTP server affecting deployments that enable proxy.connect-udp and accept CONNECT-UDP requests. A client can send an incomplete CONNECT-UDP Capsule with a large declared length, causing the server to buffer data without limits and potentially exhaust memory, leading to denial of service. The issue is fixed in commit 4212ce114506a073505fd389db16ad2ba4e582a0.
CVE-2026-55368 is a high-severity out-of-bounds write vulnerability in the h2o HTTP server's access-log formatter. The flaw occurs when certain custom access-log formats are configured, allowing writes past the log-line buffer. This can cause server crashes or potentially other undefined behavior due to a one-byte null byte overwrite. The vulnerability is fixed in a specific commit identified by the vendor.
CVE-2026-103002 is an authorization bypass vulnerability in GPUStack versions 2.2.0 through 2.2.1. The cluster_apiserver_proxy component forwarded authenticated non-administrator requests to Kubernetes clusters without proper resource-level authorization checks, using a worker's Kubernetes ServiceAccount credentials. This allowed attackers to read sensitive data, modify workloads, or delete resources within the permissions of that ServiceAccount. Exploitation requires a Kubernetes cluster with a reachable worker and attacker-controlled workloads, potentially leading to code execution. The issue is fixed in GPUStack version 2.2.2.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD stores potentially sensitive information in log files that could be read by a local user.
Jan from 0.8.5 before 0.8.8 contains a workspace guard bypass vulnerability in the agent-tools gate.rs that allows attackers to write files outside the workspace via dangling symlinks. Attackers supplying a malicious repository can use prompt injection to make the write or edit tools follow symlinks, creating files like ~/.ssh/authorized_keys on the host.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD is vulnerable to an XML external entity injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD Managed File Transfer could allow an authenticated attacker to obtain sensitive information or cause a denial of service due to improper restriction of XML external entity references in command queue processing.
IBM MQ 9.4.0.0 to 9.4.0.26, 9.4.1.0 to 9.4.5.3, and 10.0.0.1 to 10.0.0.5 could allow an authenticated attacker to obtain sensitive information or cause a denial of service due to improper validation of message header structure length fields.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated attacker to execute arbitrary code by injecting malicious environment variables through transfer request metadata.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD is vulnerable to an XML external entity injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated user with command queue access to execute arbitrary code by injecting malicious arguments into Ant script commands.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow a remote authenticated attacker to cause a denial of service and perform limited memory corruption due to an integer overflow.