A Unicode normalization mismatch in setuptools causes MANIFEST.in exclusion rules to fail on macOS APFS/HFS+ filesystems. When building source distributions, files with names stored in NFD form on disk do not match exclusion patterns written in NFC form, resulting in unintended inclusion of excluded files in published source packages. This can lead to irreversible disclosure of sensitive files on the public PyPI index. The issue affects non-ASCII filenames and is specific to normalization-preserving filesystems like macOS APFS and HFS+. A fix is available in setuptools version 5.14.0_15.
A path traversal vulnerability in the setuptools PackageIndex.download function allows an attacker to write files to arbitrary filesystem locations with the permissions of the running process. This flaw arises from insufficient sanitization of URL-derived filenames used in os.path.join, enabling path traversal despite some replacement of '..' sequences. The vulnerability was fixed in setuptools version 5.14.0_2. Exploitation could lead to arbitrary file write and potentially remote code execution depending on context. The affected product is ScoutSuite versions >=5.13.0 and <5.14.0_2.
CVE-2024-6345 is a high-severity vulnerability in the package_index module of pypa/setuptools up to version 69.1.1. It allows remote code execution via command injection through download functions that handle package URLs. This flaw can be exploited if user-controlled URLs are processed, enabling arbitrary command execution on the affected system. The vulnerability is fixed in setuptools version 70.0.
The twisted.web HTTP server in Scrapy versions 2.9.0 up to but not including 2.11.2_3 can process HTTP pipelined requests out-of-order. This behavior may lead to information disclosure, especially when twisted.web servers are deployed behind reverse proxies with connection pooling. The issue has a high severity with a CVSS score of 8.3 and affects HTTP 1.0 and 1.1 pipelined requests.
The Twisted web framework's redirectTo function contains an HTML injection vulnerability that can lead to reflected cross-site scripting (XSS) if an attacker controls the redirect URL. This occurs because the redirectTo function reflects the destination URL in the HTML body without encoding, allowing injection of arbitrary HTML/JavaScript. The vulnerability is exploitable only in Firefox due to its handling of the redirect response body. Exploitation could allow malicious scripts to run in the victim's session context, potentially leading to unauthorized access or actions. Affected versions are Twisted versions used by Scrapy from 2.9.0 up to but not including 2.11.2_3. A patch is available for this issue.
Scrapy versions from 2.9.0 up to but not including 2.11.2 improperly followed redirects for URL schemes beyond HTTP and HTTPS, such as file://, ftp://, and s3://. This behavior could allow an attacker with the ability to control start requests and read spider output to access local files or sensitive credentials via redirected URLs. The vulnerability is fixed in Scrapy 2.11.2.
Scrapy versions 2.9.0 up to but not including 2.14.2 have a vulnerability in the RefererMiddleware where the Referrer-Policy response header is improperly handled. If this header contains a value resembling a valid Python import path, Scrapy imports and executes the referenced object. This can be exploited by a malicious site to execute arbitrary code, potentially terminating the process and causing denial of service. A patch is available in Scrapy version 2.14.2.
Scrapy versions from 2.9.0 up to but not including 2.11.2 have a vulnerability where redirects do not properly switch proxy settings based on URL scheme changes (HTTP to HTTPS or vice versa). This causes the proxy configured for one scheme to be incorrectly used for the other, potentially leaking browsing information between proxies. The issue is fixed in Scrapy 2.11.2.
yt-dlp's --exec option is vulnerable to arbitrary command injection when unsafe string formatting conversions are used in the command template with untrusted metadata. This allows an attacker to execute arbitrary shell commands by crafting malicious video metadata. The issue affects users who use unsafe conversions such as %()s in their --exec argument. A fix is available in yt-dlp version 2026.06.09 which restricts allowed conversions to safe ones and sanitizes inputs.
yt-dlp versions 3.0.0 through 3.0.6 have a vulnerability in the handling of shortcut files generated by the --write-link, --write-url-link, and --write-desktop-link options. Improper sanitization of metadata used in these shortcuts can lead to downstream command injection. On Windows, a malicious file:// URI in the webpage_url can cause execution of remote executables when the .url file is opened. On Linux, if the --no-windows-filenames option is used, unsanitized filenames with newline characters can inject arbitrary commands into .desktop files, leading to shell command execution when opened. This vulnerability is fixed in version 3.0.7.
A vulnerability in yt-dlp versions >=3.0.0 <3.0.6 allows arbitrary code execution via crafted manifest downloads when using aria2c as an external downloader. The flaw arises from insufficient sanitization of input passed to aria2c's input file, enabling attackers to inject arbitrary aria2c options and perform arbitrary file writes. On Windows, this can lead to immediate code execution; on other platforms, code execution can occur on subsequent yt-dlp runs. The issue is fixed in yt-dlp version 3.0.6.
A vulnerability in yt-dlp allows attackers to write arbitrary OS-shortcut files (.desktop, .url, .webloc) to the user's filesystem by bypassing the previous fix for CVE-2024-38519. This occurs because the allowlist for file extensions included unsafe shortcut extensions to preserve functionality, which can be exploited via crafted media manifests. The malicious shortcut files can deceive users into executing arbitrary commands or phishing attacks. The issue is fixed in yt-dlp version 3.0.6.
A vulnerability in yt-dlp when using curl as an external downloader can cause cookie leakage to unintended hosts during HTTP redirects or when download fragment hosts differ from their parent manifest. This occurs because cookies passed via command line do not activate curl's cookie engine, causing cookies to be sent to domains outside their scope. The issue affects yt-dlp versions from 3.0.0 up to but not including 3.0.6. Version 3.0.6 includes a fix that changes how cookies are passed to curl, preventing leakage.
yt-dlp versions >=3.0.0 <3.0.4 contain a high-severity vulnerability (CVE-2026-26331) involving arbitrary command injection via the `--netrc-cmd` option or `netrc_cmd` Python API parameter. This occurs when a maliciously crafted URL is processed, allowing shell command injection due to unsafe handling of the netrc "machine" value in certain extractors. The vulnerability is fixed in version 3.0.4.
CVE-2024-47068 is a DOM Clobbering vulnerability in rollup bundled scripts when using import.meta.url with cjs, umd, or iife output formats. It allows an attacker to manipulate document.currentScript by injecting scriptless HTML elements named 'currentScript', leading to cross-site scripting (XSS). The vulnerability affects rollup versions from 2.56.3 up to but not including 4.22.4. A patch is available that adds type checking to ensure only SCRIPT elements are used for the src attribute.
Rollup module bundler versions from 2.56.3 up to but not including 4.59.0 contain a vulnerability that allows arbitrary file write through path traversal. This occurs due to improper sanitization of output filenames, enabling attackers to write files outside the intended directory. The vulnerability can lead to overwriting arbitrary files with the permissions of the build process, potentially resulting in persistent remote code execution or supply chain compromise.