HTTP::Parser::XS versions before 0.18 for Perl have a vulnerability where the PATH_INFO is truncated at an encoded NUL byte (%00) during HTTP request parsing. This occurs because the XS parser URL-decodes the request path and uses strlen() to measure it, causing the path to end prematurely at the first decoded NUL byte. The pure-Perl backend is not affected. This discrepancy can allow a remote attacker to send a path that a proxy or filter inspects fully, while the application routes on a truncated, shorter path.
Dell OpenManage Enterprise versions prior to 4.8.0 contain an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. This flaw allows a low privileged attacker with remote access to potentially expose sensitive information. The vulnerability has a high severity rating with a CVSS score of 7.1. No specific patch information is provided in the input data.
Dell OpenManage Enterprise versions prior to 4.8.0 have an Improper Restriction of Excessive Authentication Attempts vulnerability (CWE-307). This flaw allows an unauthenticated attacker with adjacent network access to potentially exploit the system, which could lead to phishing attacks. The vulnerability has a CVSS 3.1 score of 5.4 (medium severity). No patch or remediation details are provided in the available data.
Starlet versions from 0.20 up to but not including 0.33 for Perl contain a vulnerability that allows remote attackers to exhaust memory via unbounded buffering when decoding chunked request bodies. The vulnerability arises because the decoder accumulates input in a buffer without limiting the length of chunk-size lines or the data of large chunks, enabling a single request to consume excessive memory.
Dell OpenManage Enterprise versions prior to 4.8.0 contain an Insufficiently Protected Credentials vulnerability (CVE-2026-111502). This flaw allows a low privileged attacker with remote access to potentially disclose sensitive information. The vulnerability does not affect integrity or availability but impacts confidentiality. The CVSS score is 4.3 (medium severity).
CallBackery versions prior to 0.60.1 for Perl contain a path traversal vulnerability in the /doc route that allows unauthenticated clients to read the POD (Plain Old Documentation) of any file accessible by the server process. This occurs because the documentation plugin mounted at /doc does not validate input before passing it to Pod::Simple::Search->find, enabling traversal outside the intended directories.
Starlet versions from 0.20 up to but not including 0.33 for Perl contain a vulnerability that allows CPU exhaustion via regular expression backtracking when decoding chunked request bodies. The flaw arises because the chunk-size line matching can cause the regex engine to retry matches quadratically with the length of the input, and there is no limit on the length of the run. A remote attacker can exploit this by sending a specially crafted 128 KiB request, causing a worker to consume about a minute of CPU time.
FOSSBilling versions before 0.8.9 have a Cross-Site Request Forgery (CSRF) vulnerability in the staff guest login endpoint. This flaw allows remote attackers to force authentication by exploiting missing CSRF or Origin validation on the staff_login action. An attacker can craft an auto-submitting HTML form with attacker-controlled credentials to silently log a victim's browser into the attacker's staff account.
Starlet versions before 0.33 for Perl improperly send a body in responses to HEAD requests, causing corruption of subsequent responses on persistent or pipelined HTTP connections. This occurs because the request method is not passed to the response writer, resulting in unintended body content being sent. This behavior can desynchronize clients or proxies sharing the connection.
A time-of-check to time-of-use (TOCTOU) race condition in the Linux kernel's net/sched act_api component could lead to a NULL pointer dereference. The issue arises from separate reads of a pointer that may be cleared concurrently, causing a NULL dereference in tcf_action_goto_chain_exec(). The flaw has been fixed by consolidating the pointer read and check into a single operation.
Python's ssl module has been updated to include a denylist of known compromised intermediate certificates. This enhancement ensures that such certificates are automatically rejected regardless of the SSLContext policy configuration, improving user security even when certificate revocation is not configured. The vulnerability affects multiple Python versions prior to their respective fixed releases.
The npm package 'tabby-fknat' version 0.1.2 contains malicious code that can fully compromise any computer on which it is installed or running. This compromise includes potential unauthorized access to all secrets and keys stored on the affected system. Immediate removal of the package is advised, but due to the extent of the compromise, complete remediation may require rotating all secrets and keys from a different, trusted machine.
RTIR extends RT's HTML scrubber to allow an internal link
placeholder, and the extension lets through any link that merely
contains the placeholder, including links using the executable
javascript: scheme. The change applies to the whole RT instance
once RTIR is installed, not only to RTIR's own queues. Anyone who
can add HTML content to a ticket on such an instance can store
such a link. That includes an unauthenticated sender of HTML email
to the Incident Reports queue, which RTIR opens to everyone by
default. Script runs when a user clicks the link, in that user's
session, and can act in RT with that user's authority.
This issue was fixed in version 5.0.11 and 6.0.4
Blender before 4.5.15 and 5.x before 5.2.3 contains a heap out-of-bounds access vulnerability in read_struct() that skips size validation when a .blend file's SDNA struct layout compares equal. Attackers can supply a crafted .blend file with short blocks so field reads, writes, and pointer dereferences overrun heap memory, causing crashes or code execution.
Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read vulnerability in blo_bhead_id_* accessors in readfile.cc that read ID fields without block length checks. Attackers can supply a crafted .blend file with short ID blocks that, when browsed or appended from, causes heap over-reads leading to crashes or heap memory disclosure.
CVE-2026-119720 is a heap out-of-bounds read vulnerability in Blender versions before 4.5.15 and 5.x before 5.2.3. It occurs in the read_file_dna() function when processing a crafted .blend file with a truncated GLOB block, leading to a crash.
Blender versions before 4.5.15 and 5.x before 5.2.3 have a heap buffer overflow vulnerability in the blend file thumbnail extractor. This is caused by a 32-bit integer overflow in the thumb_data_vertical_flip() function. Maliciously crafted .blend files with specially designed TEST block dimensions can trigger out-of-bounds writes when previewed by blender-thumbnailer or the Windows shell extension, potentially leading to crashes or code execution.
Blender versions before 4.5.15 and 5.x before 5.2.3 have a heap buffer overflow vulnerability due to an integer overflow in the ptcache_data_alloc() function when reading point cache files. An attacker can craft a malicious point cache file with a large totpoint value alongside a .blend file to cause a crash or potentially execute arbitrary code with user privileges.
pybars4 through 0.9.13 contains a code injection vulnerability in pybars/_compiler.py that allows attackers to execute Python code via unescaped bracketed path segments in Handlebars templates. Attackers can supply a template with a crafted segment in a helper or block argument to break out of the generated resolve() string literal and execute code in the application process.