Skip to main content
VulnerabilityPublished Updated

CVE-2026-92391: curl · A deeply nested multipart MIME structure constructed via the public API causes a stack overflow in

Affects curlSource GCVE Database

0
Compare
Authoritative record:CVE-2026-92391· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 7.58.0-2ubuntu3.24+esm15 : patch curl soon.

Data as of 3 Nov 2026, 23:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 7.58.0-2ubuntu3.24+esm15, 7.68.0-1ubuntu2.25+esm10, 7.81.0-1ubuntu1.30 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10curlpkg:deb/ubuntu/curl?arch=source&distro=stonkingOther threatsAffected
  • <8.20.0-2ubuntu11.1
Fixed in
  • 8.20.0-2ubuntu11.1
Ubuntu 26.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=resoluteOther threatsAffected
  • <8.18.0-1ubuntu2.8
Fixed in
  • 8.18.0-1ubuntu2.8
Ubuntu 24.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=nobleOther threatsAffected
  • <8.5.0-2ubuntu10.16
Fixed in
  • 8.5.0-2ubuntu10.16
Ubuntu 22.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=jammyOther threatsAffected
  • <7.81.0-1ubuntu1.30
Fixed in
  • 7.81.0-1ubuntu1.30
Ubuntu Pro 20.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra/focalOther threatsAffected
  • <7.68.0-1ubuntu2.25+esm10
Fixed in
  • 7.68.0-1ubuntu2.25+esm10
Ubuntu Pro 18.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <7.58.0-2ubuntu3.24+esm15
Fixed in
  • 7.58.0-2ubuntu3.24+esm15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The vulnerability is fixed in Ubuntu package versions 7.58.0-2ubuntu3.24+esm15, 7.68.0-1ubuntu2.25+esm10, 7.81.0-1ubuntu1.30, 8.5.0-2ubuntu10.16, 8.20.0-2ubuntu11.1, and 8.18.0-1ubuntu2.8. Users should upgrade to these or later versions to remediate the issue.

Description

A vulnerability in libcurl allows a stack overflow due to excessive recursion when processing deeply nested multipart MIME structures via the public API. This occurs during normal cleanup operations in the curl_mime_free function, causing the host process to crash. The issue affects multiple Ubuntu package versions of curl and has been assigned CVE-2026-92391 with a high severity rating.

References

Community reviews

Loading reviews…