Skip to main content
CVE-2026-92390VulnerabilityPublished Updated

When invoked with --remote-header-name (-J), curl fails to preserve its documented anti-clobbering protection if an

Affects curlSource GCVE Database

0
Compare
Authoritative record:CVE-2026-92390· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 8.20.0-2ubuntu11.1 : patch curl soon.

Data as of 3 Nov 2026, 23:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 8.20.0-2ubuntu11.1, 8.18.0-1ubuntu2.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu curl to 8.20.0-2ubuntu11.1 (package) or 8.18.0-1ubuntu2.8 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10curlpkg:deb/ubuntu/curl?arch=source&distro=stonkingOther threatsAffected
  • <8.20.0-2ubuntu11.1
Fixed in
  • 8.20.0-2ubuntu11.1
Ubuntu 26.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=resoluteOther threatsAffected
  • <8.18.0-1ubuntu2.8
Fixed in
  • 8.18.0-1ubuntu2.8
Ubuntu Pro 20.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra/focalOther threatsAffected
  • 7.65.3-1ubuntu3 – 7.68.0-1ubuntu2.25+esm10
35 affected builds
Fixed in–
Ubuntu Pro 18.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 7.55.1-1ubuntu2 – 7.58.0-2ubuntu3.24+esm15
41 affected builds
Fixed in–
Ubuntu Pro 16.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 7.43.0-1ubuntu2 – 7.47.0-1ubuntu2.19+esm21
41 affected builds
Fixed in–
Ubuntu Pro 14.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 7.32.0-1ubuntu1 – 7.35.0-1ubuntu2.20+esm24
46 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The issue is fixed in curl versions 8.20.0-2ubuntu11.1 and 8.18.0-1ubuntu2.8 as per the Ubuntu security advisory USN-8927-1. Users should upgrade to these or later versions to mitigate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in curl occurs when using the --remote-header-name (-J) option. If an intermediate 103 Early Hints HTTP response precedes the final response, or if an ETag header is processed before Content-Disposition under --etag-save, curl fails to enforce its anti-clobbering protection. This allows an HTTP(S) server to overwrite an existing local file despite the -J option's non-overwrite intent. The issue affects multiple versions of curl and has been fixed in specific Ubuntu package releases.

References

Community reviews

Loading reviews…