Skip to main content
VulnerabilityPublished Updated

CVE-2026-87863: Curl · An authenticated HTTPS origin can supply an HSTS max-age value that the parser accepts, but

Affects curlSource GCVE Database

0
Compare
Authoritative record:CVE-2026-87863· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in 8.5.0-2ubuntu10.16 : patch curl soon.

Data as of 3 Nov 2026, 23:35 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.1
Patch
Available – fixed in 8.5.0-2ubuntu10.16, 8.20.0-2ubuntu11.1, 8.18.0-1ubuntu2.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu curl to 8.5.0-2ubuntu10.16 (package) or 8.20.0-2ubuntu11.1 (package) or 8.18.0-1ubuntu2.8 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10curlpkg:deb/ubuntu/curl?arch=source&distro=stonkingOther threatsAffected
  • <8.20.0-2ubuntu11.1
Fixed in
  • 8.20.0-2ubuntu11.1
Ubuntu 26.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=resoluteOther threatsAffected
  • <8.18.0-1ubuntu2.8
Fixed in
  • 8.18.0-1ubuntu2.8
Ubuntu 24.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=nobleOther threatsAffected
  • <8.5.0-2ubuntu10.16
Fixed in
  • 8.5.0-2ubuntu10.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: 8.5.0-2ubuntu10.16, 8.20.0-2ubuntu11.1, and 8.18.0-1ubuntu2.8. Users should upgrade to these or later versions to remediate the issue. The vendor advisory confirms patch availability and recommends applying these updates. No additional mitigations are indicated.

Description

Curl versions prior to fixed releases improperly handle HSTS max-age values that exceed calendar time structure bounds on 64-bit systems. This causes serialization failures during cache saves, leading to truncation and deletion of the HSTS cache file, resulting in data loss. The error is silently ignored, and curl exits successfully despite the cache corruption.

References

Community reviews

Loading reviews…