Skip to main content
CVE-2026-42533VulnerabilityPublished Updated

NGINX Plus · Vulnerability Exists

Affects nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2026-42533· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in 1.18.0-6ubuntu14.21 : patch nginx soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.18.0-6ubuntu14.21, 1.24.0-2ubuntu7.18, 1.28.3-2ubuntu1.11
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu nginx to 1.18.0-6ubuntu14.21 (package) or 1.24.0-2ubuntu7.18 (package) or 1.28.3-2ubuntu1.11 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.11
Fixed in
  • 1.28.3-2ubuntu1.11
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.18
Fixed in
  • 1.24.0-2ubuntu7.18
Ubuntu 22.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=jammyOther threatsAffected
  • <1.18.0-6ubuntu14.21
Fixed in
  • 1.18.0-6ubuntu14.21
Ubuntu Pro 20.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.16.1-0ubuntu2 – 1.18.0-0ubuntu1.7+esm3
21 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.1-0ubuntu2 – 1.14.0-0ubuntu1.11+esm4
19 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 1.9.3-1ubuntu1 – 1.10.3-0ubuntu0.16.04.5+esm9
30 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and a string expression references the map's regex capture variables before referencing the map output variable. Alternatively, the same result could be achieved by using a non-cacheable variable in a string expression under certain conditions. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or to possibly trigger a code execution. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…