CVE-2024-53948: Apache Superset · Error verbosity exposes metadata in analytics databases
Affects supersetSource GCVE Database
Not known to be exploited : upgrade to 4.1.1 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade superset to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamisupersetpkg:bitnami/supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Superset to version 4.1.0 or later, where this issue is fixed. Since a patch is available, applying the official update is the recommended remediation.
Description
Apache Superset versions before 4.1.0 contain a vulnerability where error messages expose metadata information from analytics databases. This issue can leak sensitive metadata through verbose error messages. The vulnerability is fixed in version 4.1.0.