CVE-2024-24773: Apache Superset · Improper validation of SQL statements allows for unauthorized access to data
Affects supersetSource GCVE Database
Not known to be exploited : upgrade to 4.1.1 when convenient.
Data as of 26 Oct 2026, 09:15 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade superset to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamisupersetpkg:bitnami/supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Superset to version 3.1.1 or later, where this vulnerability has been fixed. No other mitigation actions are indicated by the vendor advisory.
Description
Apache Superset contains a vulnerability in SQLLab where improper parsing of nested SQL statements allows authenticated users to access data beyond their authorization scope. This affects versions before 3.0.4 and versions from 3.1.0 up to but not including 3.1.1. The issue is fixed in version 3.1.1. No known exploits are reported in the wild.