CVE-2024-24779: Apache Superset · Improper data authorization when creating a new dataset
Affects supersetSource GCVE Database
Not known to be exploited : upgrade to 4.1.1 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade superset to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamisupersetpkg:bitnami/supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Superset to version 3.0.4 or 3.1.1 or later, where this vulnerability is fixed. Applying these official fixes will prevent unauthorized data access via virtual dataset creation. No additional mitigation steps are indicated by the vendor advisory.
Description
Apache Superset versions before 3.0.4 and from 3.1.0 before 3.1.1 contain a vulnerability that allows users with custom roles including 'can write on dataset' but without full data access permissions to create virtual datasets accessing unauthorized data. This improper data authorization flaw can lead to unauthorized data exposure. The issue is fixed in versions 3.0.4 and 3.1.1.