CVE-2024-27315: Apache Superset · Improper error handling on alerts
Affects supersetSource GCVE Database
Not known to be exploited : upgrade to 4.1.1 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade superset to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamisupersetpkg:bitnami/supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Superset to version 3.0.4 or 3.1.1 or later, where this improper error handling issue has been fixed. Since a patch is available, applying the official fix is the recommended mitigation.
Description
Apache Superset contains an improper error handling vulnerability in its Alerts feature that affects versions before 3.0.4 and from 3.1.0 before 3.1.1. An authenticated user with privileges to create Alerts can craft a SQL statement that triggers a database error, which is not properly handled and may expose sensitive data in error logs. Upgrading to versions 3.0.4 or 3.1.1 resolves this issue.