Skip to main content
VulnerabilityPublished Updated

CVE-2024-34693: Apache Superset · Server arbitrary file read

Affects supersetSource GCVE Database

0

Not known to be exploited : upgrade to 4.1.1 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.5% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade superset to 4.1.1.

Affected software

ProductAffectedFixed in
Bitnamisupersetpkg:bitnami/supersetOther threatsAffected
  • <4.1.1
Fixed in
  • 4.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available. Users should upgrade Apache Superset to version 3.1.3 or 4.0.1 to remediate this vulnerability. Ensure that the MariaDB server and local MySQL client do not have local_infile enabled unless explicitly required and secured. No additional mitigation steps are indicated by the vendor advisory.

Description

Apache Superset contains an improper input validation vulnerability (CVE-2024-34693) that allows an authenticated attacker to create a MariaDB connection with local_infile enabled. If the MariaDB server and the local MySQL client on the web server both permit local infile, the attacker can execute SQL commands to read arbitrary files from the server and insert their contents into a MariaDB database table. This affects versions before 3.1.3 and version 4.0.0. Upgrading to versions 3.1.3 or 4.0.1 resolves the issue.

References

Community reviews

Loading reviews…