Skip to main content
CVE-2024-39887VulnerabilityPublished Updated

CVE-2024-39887: Apache Superset · Improper SQL authorisation, parse not checking for specific engine functions

Affects supersetSource GCVE Database

0

Not known to be exploited · public detection template (Nuclei) : upgrade to 4.1.1 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
4.4% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2025

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade superset to 4.1.1.

Affected software

ProductAffectedFixed in
Bitnamisupersetpkg:bitnami/supersetOther threatsAffected
  • <4.1.1
Fixed in
  • 4.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Superset to version 4.0.2 or later, which includes the fix introducing the DISALLOWED_SQL_FUNCTIONS configuration to block dangerous PostgreSQL functions. Users can also customize this configuration to add additional disallowed functions for enhanced protection.

Description

Apache Superset versions before 4.0.2 contain an SQL Injection vulnerability due to improper authorization checks on certain PostgreSQL engine-specific functions. This allows attackers to bypass SQL authorization by exploiting functions such as version, query_to_xml, inet_server_addr, and inet_client_addr. The vulnerability is fixed in version 4.0.2 by introducing a configuration key to disallow these functions.

References

Community reviews

Loading reviews…