Skip to main content
CVE-2024-53949VulnerabilityPublished Updated

CVE-2024-53949: Apache Superset · Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled

Affects supersetSource GCVE Database

0

Not known to be exploited : upgrade to 4.1.1 soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade superset to 4.1.1.

Affected software

ProductAffectedFixed in
Bitnamisupersetpkg:bitnami/supersetOther threatsAffected
  • >=2.0.0 <4.1.1
Fixed in
  • 4.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Superset to version 4.1.0 or later, where this vulnerability is fixed. Since the vulnerability only manifests when FAB_ADD_SECURITY_API is enabled (disabled by default), disabling this feature can also mitigate risk if upgrading is not immediately possible.

Description

Apache Superset contains an improper authorization vulnerability when the FAB_ADD_SECURITY_API feature is enabled, which is disabled by default. This flaw allows lower privilege users to create roles via the security API. The issue affects versions from 2.0.0 up to but not including 4.1.1. Upgrading to version 4.1.0 or later resolves the vulnerability.

References

Community reviews

Loading reviews…