Skip to main content
VulnerabilityPublished Updated

CVE-2024-55633: Apache Superset · SQLLab Improper readonly query validation allows unauthorized write access

Affects supersetSource GCVE Database

0

Not known to be exploited : upgrade to 4.1.1 soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
2.8% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade superset to 4.1.1.

Affected software

ProductAffectedFixed in
Bitnamisupersetpkg:bitnami/supersetOther threatsAffected
  • <4.1.1
Fixed in
  • 4.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Superset to version 4.1.0 or later, where this vulnerability is fixed. Additionally, configuring Postgres analytic database connections with a read-only user prevents exploitation. No other mitigation is indicated by the vendor advisory.

Description

Apache Superset before version 4.1.0 contains an improper authorization vulnerability in SQLLab when used with Postgres analytic databases. An attacker with SQLLab access can craft a SQL DML statement that is incorrectly identified as read-only, allowing unauthorized write operations. This issue does not affect non-Postgres analytic databases or Postgres connections configured with a read-only user. The vulnerability is fixed in Apache Superset version 4.1.0.

References

Community reviews

Loading reviews…