Skip to main content
Report · Tenable ResearchAbout CVE-2026-111497Published

CVE-2026-111497: Brotli2Shell · Frequently asked questions for Google Brotli decoder vulnerability

Source Tenable Research

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical · fixed in 1.2.1 : patch Brotli as a priority.

Data as of 27 Oct 2026, 02:42 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.1, 1.1.1, 1.0.10
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Brotli and github.com/google/brotli to 1.2.1, 1.1.1 or 1.0.10.

Affected software

ProductAffectedFixed in
Brotligithub.com/google/brotliAffected
  • >=1.2.0 <1.2.1
Fixed in
  • 1.2.1
Brotligithub.com/google/brotliAffected
  • >=1.1.0 <1.1.1
Fixed in
  • 1.1.1
Brotligithub.com/google/brotliAffected
  • >=1.0.3 <1.0.10
Fixed in
  • 1.0.10
GitHubgithub.com/google/brotlipkg:github/github.com/google/brotliOther threatsAffected
  • >=1.0.3 <1.0.10
  • >=1.1.0 <1.1.1
  • >=1.2.0 <1.2.1
Fixed in
  • 1.0.10
  • 1.1.1
  • 1.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions of the Brotli library and affected runtimes have been released and should be applied promptly. Google Brotli fixed releases start at 1.0.10, 1.1.1, and 1.2.1. Node.js fixed releases include 22.23.4, 24.22.1, and 26.12.1. Envoy Proxy fixed releases start at 1.36.12, 1.37.8, 1.38.6, 1.39.3, and 1.40.0. Istio fixed releases are 1.29.9, 1.30.6, and 1.31.2. Microsoft .NET fixed versions are 8.0.33, 9.0.22, 10.0.14, and Release Candidate 3 for .NET 11. Python Brotli and brotlicffi packages fixed at 1.2.1 and 1.2.1.0 respectively. PHP for Windows builds bundling Brotli fixed at versions 8.2.35-1, 8.3.36-1, 8.4.27-1, and 8.5.12-1. Applications bundling their own Brotli decoder must update their embedded library. Systems using the OS Brotli library will be protected after updating and restarting affected applications. End-of-support Node.js versions do not have fixes and should be upgraded to supported versions. No vendor advisory states that no action is required; patching is necessary.

Description

CVE-2026-111497, known as Brotli2Shell, is a critical out-of-bounds write vulnerability in Google's Brotli C decoder library. It affects many widely used software projects that decompress Brotli data, including Node.js, .NET, Bun, Envoy Proxy, Istio, Python HTTP clients, FFmpeg, Apache Arrow, ClickHouse, and PHP for Windows. The flaw can be triggered by decompressing crafted Brotli data, potentially leading to process crashes, memory leaks, or remote code execution. The vulnerability has a high CVSSv4.0 score of 9.2 assigned by Google. Patches have been released for the Brotli library and major runtimes, but some projects had not shipped fixed releases as of late October 2026. Applications bundling their own Brotli decoder require individual updates.

References

Community reviews

Loading reviews…