Skip to main content
CVE-2026-39948VulnerabilityPublished Updated

Cacti:

Affects cactiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.8 Critical · fixed in 1.2.31 : patch cacti as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.31
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10cactipkg:deb/ubuntu/cacti?arch=source&distro=stonkingOther threatsAffected
  • =1.2.30+ds1-1ubuntu2
  • =1.2.30+ds1-1ubuntu3
  • =1.2.31+ds1-3ubuntu2
Fixed in–
Ubuntu 26.04 LTScactipkg:deb/ubuntu/cacti?arch=source&distro=resoluteOther threatsAffected
  • =1.2.30+ds1-1ubuntu1
  • =1.2.30+ds1-1ubuntu2
Fixed in–
Ubuntu 25.10cactipkg:deb/ubuntu/cacti?arch=source&distro=questingOther threatsAffected
  • =1.2.28+ds1-4ubuntu1
  • =1.2.30+ds1-1ubuntu1
Fixed in–
Ubuntu 24.04 LTScactipkg:deb/ubuntu/cacti?arch=source&distro=nobleOther threatsAffected
  • =1.2.25+ds1-2
  • =1.2.26+ds1-1
  • =1.2.26+ds1-1ubuntu0.1
Fixed in–
Ubuntu Pro 22.04 LTScactipkg:deb/ubuntu/cacti?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1.2.16+ds1-2ubuntu1 – 1.2.19+ds1-2ubuntu1+esm1
6 affected builds
Fixed in–
Ubuntu Pro 20.04 LTScactipkg:deb/ubuntu/cacti?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1.2.4+ds1-2ubuntu3 – 1.2.10+ds1-1ubuntu1+esm1
8 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Cacti to version 1.2.31 or later, where this vulnerability is fixed. No other mitigation is indicated or required as the fix addresses the root cause by properly validating the rfilter parameter before use in SQL queries.

Description

Cacti versions 1.2.30 and earlier contain a SQL injection vulnerability in the handling of the rfilter request parameter. The parameter is retrieved without proper regex validation and directly concatenated into SQL RLIKE clauses, allowing unauthenticated attackers to inject arbitrary SQL. This vulnerability affects installations with guest graph viewing enabled and can compromise database confidentiality, integrity, and availability. The issue is fixed in version 1.2.31.

References

Community reviews

Loading reviews…