Skip to main content
VulnerabilityPublished

CVE-2026-116688: CKEditor · Cross-site scripting (XSS) in the engine package

Affects ckeditor5Source GCVE Database

0
Authoritative record:CVE-2026-116688· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 47.7.4 soon.

Data as of 27 Oct 2026, 22:27 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 47.7.4, 48.5.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ckeditor5 and @ckeditor/ckeditor5-engine to 47.7.4; ckeditor5 and @ckeditor/ckeditor5-engine to 48.5.1.

Affected software

ProductAffectedFixed in
npmckeditor5Affected
  • >=45.0.0 <47.7.4
Fixed in
  • 47.7.4
npm@ckeditor/ckeditor5-engineAffected
  • >=45.0.0 <47.7.4
Fixed in
  • 47.7.4
npmckeditor5Affected
  • >=48.0.0 <48.5.1
Fixed in
  • 48.5.1
npm@ckeditor/ckeditor5-engineAffected
  • >=48.0.0 <48.5.1
Fixed in
  • 48.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade CKEditor 5 to version 47.7.4 (LTS) or 48.5.1 and later to apply the official fix. No additional mitigation is required as the vulnerability is patched in these versions.

Description

A Cross-Site Scripting (XSS) vulnerability exists in CKEditor 5 due to a prototype pollution issue in the es-toolkit library. This flaw allows unauthorized JavaScript execution when processing style attribute values. The vulnerability is fixed in CKEditor 5 versions 47.7.4 (LTS) and 48.5.1 and later.

References

Community reviews

Loading reviews…