Skip to main content
VulnerabilityPublished

CVE-2026-95838: containerd security update

Affects containerdSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.6.22-33.oe2403sp1 when convenient.

Data as of 29 Oct 2026, 11:04 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.22-33.oe2403sp1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade containerd to 1.6.22-33.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1containerdpkg:rpm/openEuler/containerd&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <1.6.22-33.oe2403sp1
Fixed in
  • 1.6.22-33.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fixes by upgrading containerd to versions 1.7.35, 2.0.12, 2.2.8, or 2.3.5 or later. These versions contain the patch that resolves the repeated directory traversal issue during opaque whiteout processing. No other mitigation actions are indicated.

Description

CVE-2026-95838 is a vulnerability in containerd, an industry-standard container runtime. Prior to versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5, the layer unpack handler could be exploited by a malicious image layer that triggers repeated directory traversals during opaque whiteout processing. This can cause high CPU usage, delay container startup, and reduce image-pull concurrency for unrelated deployments. The issue is fixed in the specified versions.

References

Community reviews

Loading reviews…