Skip to main content
VulnerabilityPublished Updated

CVE-2024-4597: GitLab · Cross-Site Request Forgery (CSRF)

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 16.11.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.11.2, 16.10.5, 16.9.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 16.11.2, 16.10.5 or 16.9.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.7.0 <16.9.7
  • >=16.10.0 <16.10.5
  • >=16.11.0 <16.11.2
Fixed in
  • 16.9.7
  • 16.10.5
  • 16.11.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab EE versions to 16.9.7 or later for the 16.7 branch, 16.10.5 or later for the 16.10 branch, and 16.11.2 or later for the 16.11 branch to remediate this issue. Applying these updates will prevent exploitation of the CSRF vulnerability.

Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in GitLab Enterprise Edition that affects certain versions from 16.7 up to but not including 16.9.7, 16.10 up to but not including 16.10.5, and 16.11 up to but not including 16.11.2. This flaw allows an attacker to force a user with an active SAML session to approve a merge request without their consent.

References

Community reviews

Loading reviews…