CVE-2023-40610: Apache Superset · Incorrect Authorization
Affects Apache SupersetSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.1.2 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 70% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Nov 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade apache-superset to 2.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIapache-supersetpkg:pypi/apache-supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately assess their Apache Superset deployments to determine if they are running affected versions (prior to 2.1.2). If you cannot patch yet, organizations should consider the following specific mitigations: 1) Disable or restrict access to the default examples database connection to prevent exploitation via the vulnerable schema. 2) Implement strict network segmentation and firewall rules to limit access to Superset instances only to trusted internal users and systems. 3) Enforce strong authentication and authorization policies at the infrastructure level to reduce the risk of low-privilege users exploiting the vulnerability. 4) Monitor Superset logs and database activity for unusual or unauthorized SQL queries, especially those involving CTEs or metadata database modifications. 5) Plan and prioritize upgrading to Apache Superset version 2.1.2 or later once patches are officially released. 6) Conduct regular security audits and penetration testing focused on Superset deployments to detect potential exploitation attempts early.
Description
Improper authorization check and possible privilege escalation on Apache Superset up to but excluding 2.1.2. Using the default examples database connection that allows access to both the examples schema and Apache Superset's metadata database, an attacker using a specially crafted CTE SQL statement could change data on the metadata database. This weakness could result on tampering with the authentication/authorization data.