CVE-2023-49083: pyca cryptography · NULL Pointer Dereference
Affects pyca cryptographySource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 41.0.6 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 41.0.6
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Nov 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade pyca cryptography to 41.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIcryptographypkg:pypi/cryptographyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade the pyca cryptography package to version 41.0.6 or later, where the NULL pointer dereference issue is resolved. For environments where immediate upgrading is not feasible, implement input validation and sanitization to restrict or verify PKCS7 certificate blobs before deserialization. Employ runtime monitoring and alerting for application crashes or segmentation faults related to cryptographic operations. Use containerization or sandboxing to isolate affected applications, minimizing the impact of potential DoS conditions. Review and harden certificate processing workflows to ensure they do not accept untrusted or malformed PKCS7 data. Additionally, conduct thorough dependency audits to identify all Python applications using the vulnerable cryptography versions. Incorporate this vulnerability into incident response plans to quickly address any exploitation attempts. Finally, maintain up-to-date threat intelligence to monitor for emerging exploits targeting this vulnerability.
Description
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Calling `load_pem_pkcs7_certificates` or `load_der_pkcs7_certificates` could lead to a NULL-pointer dereference and segfault. Exploitation of this vulnerability poses a serious risk of Denial of Service (DoS) for any application attempting to deserialize a PKCS7 blob/certificate. The consequences extend to potential disruptions in system availability and stability. This vulnerability has been patched in version 41.0.6.
References
- github.com/pyca/cryptography/security/advisories/GHSA-jfhm-5ghh-2f97 (opens in a new tab)
- github.com/pyca/cryptography/pull/9926 (opens in a new tab)
- github.com/pyca/cryptography/commit/f09c261ca10a31fe41b1262306db7f8f1da0e48a (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QMNTYMUGFJSDBYBU22FUYBHFRZODRKXV/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/10/msg00012.html (opens in a new tab)