Skip to main content
CVE-2024-21627VulnerabilityPublished Updated

CVE-2024-21627: PrestaShop · Cross-site Scripting

Affects PrestaShopSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 8.1.3 or 1.7.8.11 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.1.3, 1.7.8.11
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade prestashop/PrestaShop to 8.1.3 or 1.7.8.11.

Affected software

ProductAffectedFixed in
GitHubprestashop/PrestaShoppkg:github/prestashop/PrestaShopOther threatsAffected
  • <1.7.8.11 <8.1.3
Fixed in
  • 1.7.8.11
  • 8.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should prioritize upgrading PrestaShop installations to versions 8.1.3 or 1.7.8.11 or later, where the vulnerability is patched. If immediate upgrading is not feasible, implementing the `HTMLPurifier` library to sanitize all user-supplied HTML input is critical to mitigate the risk. Review and audit all custom and third-party modules that rely on the `isCleanHTML` method to ensure they do not process unsafe HTML content. Conduct thorough input validation and output encoding on all user inputs, especially those that can affect HTML content generation. Limit administrative access and enforce strong authentication mechanisms to reduce the likelihood of exploitation requiring authentication. Monitor web application logs for suspicious activity indicative of XSS attempts. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Finally, educate developers and administrators about secure coding practices related to HTML input handling to prevent similar vulnerabilities in the future.

Description

PrestaShop is an open-source e-commerce platform. Prior to versions 8.1.3 and 1.7.8.11, some event attributes are not detected by the `isCleanHTML` method. Some modules using the `isCleanHTML` method could be vulnerable to cross-site scripting. Versions 8.1.3 and 1.7.8.11 contain a patch for this issue. The best workaround is to use the `HTMLPurifier` library to sanitize html input coming from users. The library is already available as a dependency in the PrestaShop project. Beware though that in legacy object models, fields of `HTML` type will call `isCleanHTML`.

References

Community reviews

Loading reviews…