Skip to main content
CVE-2024-23327VulnerabilityPublished Updated

CVE-2024-23327: envoyproxy envoy · NULL Pointer Dereference

Affects envoyproxy envoySource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.26.7 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.26.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade envoyproxy/envoy to 1.26.7.

Affected software

ProductAffectedFixed in
GitHubenvoyproxy/envoypkg:github/envoyproxy/envoyOther threatsAffected
  • <1.26.7
Fixed in
  • 1.26.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary and most effective mitigation is to upgrade Envoy Proxy to one of the patched versions: 1.26.7, 1.27.3, 1.28.1, or 1.29.1 or later. Organizations should prioritize this update in their patch management cycles. In environments where immediate upgrade is not feasible, consider temporarily disabling Proxy Protocol v2 on listeners and clusters to prevent the vulnerable code path from being exercised, though this may impact legitimate traffic handling and should be tested carefully. Additionally, implement network-level protections such as filtering or rate limiting traffic that could trigger the vulnerability, especially from untrusted sources. Monitoring Envoy logs and metrics for unexpected crashes or restarts can help detect exploitation attempts. Finally, incorporate this vulnerability into incident response and vulnerability management workflows to ensure timely detection and remediation.

Description

Envoy is a high-performance edge/middle/service proxy. When PPv2 is enabled both on a listener and subsequent cluster, the Envoy instance will segfault when attempting to craft the upstream PPv2 header. This occurs when the downstream request has a command type of LOCAL and does not have the protocol block. This issue has been addressed in releases 1.29.1, 1.28.1, 1.27.3, and 1.26.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.

References

Community reviews

Loading reviews…