CVE-2024-23656: dexidp dex · Inadequate Encryption Strength
Affects dexidp dexSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 2.38.0 : patch dexidp dex soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.38.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubdexidp/dexpkg:github/dexidp/dexOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations using Dex 2.37.0 should urgently upgrade to version 2.38.0 or later, where the TLS configuration enforcement issue is fixed. Until the upgrade is applied, organizations should consider the following mitigations: 1) Implement network-level controls such as TLS interception proxies or Web Application Firewalls (WAFs) that enforce minimum TLS 1.2 usage and strong cipher suites on inbound and outbound traffic to Dex endpoints. 2) Restrict access to Dex services to trusted networks or VPNs to reduce exposure to external attackers. 3) Monitor network traffic for signs of downgrade attacks or anomalous TLS versions being negotiated. 4) Review and tighten the configuration of TLS settings in any reverse proxies or ingress controllers fronting Dex to enforce strong encryption independently. 5) Conduct thorough audits of authentication logs to detect suspicious access patterns that might indicate exploitation attempts. 6) Educate DevOps and security teams about the importance of promptly applying security patches to identity services. These steps go beyond generic advice by focusing on compensating controls and detection until the vulnerable version is replaced.
Description
Dex is an identity service that uses OpenID Connect to drive authentication for other apps. Dex 2.37.0 serves HTTPS with insecure TLS 1.0 and TLS 1.1. `cmd/dex/serve.go` line 425 seemingly sets TLS 1.2 as minimum version, but the whole `tlsConfig` is ignored after `TLS cert reloader` was introduced in v2.37.0. Configured cipher suites are not respected either. This issue is fixed in Dex 2.38.0.
References
- github.com/dexidp/dex/security/advisories/GHSA-gr79-9v6v-gc9r (opens in a new tab)
- github.com/dexidp/dex/issues/2848 (opens in a new tab)
- github.com/dexidp/dex/pull/2964 (opens in a new tab)
- github.com/dexidp/dex/commit/5bbdb4420254ba73b9c4df4775fe7bdacf233b17 (opens in a new tab)
- github.com/dexidp/dex/blob/70d7a2c7c1bb2646b1a540e49616cbc39622fb83/cmd/dex/serve.go (opens in a new tab)