CVE-2024-24549: Apache Tomcat · Improper Input Validation
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · 23% EPSS · CVSS 7.5 High : upgrade to 8.5.99 soon.
Data as of 26 Oct 2026, 11:07 UTC
- EPSS
- 23.0% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.5.99
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.tomcat/tomcat to 8.5.99.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading Apache Tomcat to the fixed versions: 11.0.0-M17, 10.1.19, 9.0.86, or 8.5.99, depending on their current deployment. In addition to patching, organizations should: 1) Review and tighten HTTP/2 header size and count limits to reasonable thresholds to reduce attack surface. 2) Implement network-level protections such as rate limiting and web application firewalls (WAFs) configured to detect and block abnormal HTTP/2 header patterns. 3) Monitor server logs and network traffic for unusual spikes in HTTP/2 requests or header anomalies indicative of exploitation attempts. 4) Employ redundancy and load balancing to mitigate potential DoS impacts. 5) Conduct regular vulnerability scans and penetration tests focusing on HTTP/2 handling. 6) Ensure incident response plans include procedures for DoS scenarios involving web servers. These steps, combined with timely patching, will significantly reduce the risk posed by this vulnerability.
Description
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
References
- lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg (opens in a new tab)
- security.netapp.com/advisory/ntap-20240402-0002/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/04/msg00001.html (opens in a new tab)
- openwall.com/lists/oss-security/2024/03/13/3 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B/ (opens in a new tab)