Skip to main content
CVE-2024-3504VulnerabilityPublished Updated

CVE-2024-3504: lunary-ai/lunary · Incorrect Authorization

Affects lunary-ai/lunarySource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 1.2.7 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.7
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade lunary-ai/lunary to 1.2.7.

Affected software

ProductAffectedFixed in
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threatsAffected
  • <1.2.7
Fixed in
  • 1.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade lunary-ai/lunary to version 1.2.7 or later, where the vulnerability is fixed. Until patching is complete, restrict admin privileges to trusted personnel only and audit admin activities closely to detect any unauthorized role changes. Implement strict role-based access controls and monitor logs for unusual privilege escalations or project deletions. Employ backup and recovery procedures to mitigate the impact of potential project deletions. Consider network segmentation and multi-factor authentication for admin accounts to reduce the risk of compromised credentials. Regularly review and update organizational policies around privilege management and incident response to quickly address any exploitation attempts. Engage with the vendor for any additional security advisories or patches related to lunary-ai/lunary.

Description

An improper access control vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, where an admin can update any organization user to the organization owner. This vulnerability allows the elevated user to delete projects within the organization. The issue is resolved in version 1.2.7.

References

Community reviews

Loading reviews…