Skip to main content
VulnerabilityPublished Updated

CVE-2024-43363: cacti · Code Injection

Affects cactiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 1.2.28 soon.

Data as of 30 Oct 2026, 00:25 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.2
Patch
Available – fixed in 1.2.28
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade cacti to 1.2.28.

Affected software

ProductAffectedFixed in
Cacti cactiAffected
  • <1.2.28
Fixed in
  • 1.2.28

AI-suggested

Upgrade Cacti to version 1.2.28 or later, where this vulnerability is fixed. There are no known workarounds. Applying the official patch is the only effective mitigation.

Description

CVE-2024-43363 is a code injection vulnerability in Cacti, an open source performance and fault management framework. An admin user can inject PHP code via a malicious hostname during the installation process, causing log poisoning. This allows remote code execution (RCE) by accessing the poisoned log file URL. The vulnerability is fixed in version 1.2.28. No workarounds are known, and users should upgrade promptly.

References

Community reviews

Loading reviews…