Skip to main content
CVE-2024-51567VulnerabilityPublished Updated

CVE-2024-51567: CyberPersons CyberPanel · n/a

Affects CyberPersons CyberPanelSource CVE Database V5

0

Exploited in the wild · used in ransomware campaigns · KEV due 28 Nov 2024 · public exploit available (Metasploit) · 84% EPSS : apply the vendor's fix or mitigations to CyberPersons CyberPanel now.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else.
Ransomware
Used in ransomware campaigns
EPSS
84.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 29 Oct 2024

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 9 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE published

    on cve.org

    , t = 0

  2. Added to CISA KEV (opens in a new tab)

    exploitation confirmed · ransomware use known

    , 9 days after disclosure

  3. KEV remediation due

    US federal deadline

    , 30 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GitHubusmannasir/cyberpanelpkg:github/usmannasir/cyberpanelOther threatsAffected
  • <=2.3.6
  • =2.3.7
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

References

Community reviews

Loading reviews…