Skip to main content
CVE-2025-15488VulnerabilityPublished

CVE-2025-15488: Responsive Plus (WordPress plugin) · Incorrect Authorization

Affects Responsive Plus (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.4.3 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Responsive Plus (WordPress plugin) to 3.4.3.

Affected software

ProductAffectedFixed in
Responsive PlusAffected
  • <3.4.3
Fixed in
  • 3.4.3

AI-suggested

1. Update the Responsive Plus plugin to version 3.4.3 or later as soon as it becomes available, as this will contain the fix for the vulnerability. 2. If you cannot patch yet, restrict access to the vulnerable AJAX endpoint by implementing web application firewall (WAF) rules that block unauthenticated requests to update_responsive_woo_free_shipping_left_shortcode. 3. Implement strict input validation and sanitization on all shortcode parameters, especially content_rech_data, to prevent execution of arbitrary shortcodes. 4. Monitor web server and WordPress logs for suspicious AJAX requests targeting this action. 5. Limit plugin usage to trusted administrators and disable unused AJAX actions if possible. 6. Employ security plugins that can detect and block unauthorized shortcode execution or anomalous AJAX activity. 7. Regularly audit WordPress plugins for updates and vulnerabilities to reduce exposure.

Description

The Responsive Plus WordPress plugin before 3.4.3 is vulnerable to arbitrary shortcode execution due to the software allowing unauthenticated users to execute the update_responsive_woo_free_shipping_left_shortcode AJAX action that does not properly validate the content_rech_data parameter before processing it as a shortcode.

References

Community reviews

Loading reviews…