Skip to main content
CVE-2025-27801VulnerabilityPublished Updated

CVE-2025-27801: Optimizely Episerver Content Management System (CMS) · XSS or 'Cross-site Scripting'

Affects Optimizely Episerver Content Management System (CMS)Source CVE Database V5

0

Not known to be exploited · CVSS 4.6 Medium · fixed in 13.0.0 : update Optimizely Episerver Content Management System (CMS) when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 13.0.0, 12.22.1, 12.0.0 +3
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:L/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade episerver.cms.core to 13.0.0, 12.22.1, 12.0.0 or 11.21.4; episerver.cms.ui to 11.37.5 or 11.37.3.

Affected software

ProductAffectedFixed in
NuGetepiserver.cms.corepkg:nuget/episerver.cms.coreOther threatsAffected
  • <11.21.4
  • >=11.0.0 <12.0.0
  • <12.22.1
  • >=12.0.0 <13.0.0
Fixed in
  • 11.21.4
  • 12.0.0
  • 12.22.1
  • 13.0.0
NuGetepiserver.cms.uipkg:nuget/episerver.cms.uiOther threatsAffected
  • <11.37.5
  • <11.37.3
Fixed in
  • 11.37.5
  • 11.37.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict the WebEditor role to trusted personnel only and monitor their activities closely. Implement strict input validation and sanitization on uploaded SVG files, potentially disabling SVG uploads if not essential. Employ Content Security Policy (CSP) headers to limit the execution of inline scripts and reduce XSS impact. Conduct regular audits of uploaded content for suspicious files. Enhance authentication mechanisms with multi-factor authentication (MFA) to reduce the risk of compromised accounts. Educate CMS users about phishing and social engineering risks that could lead to credential theft. Monitor web server logs for unusual access patterns to preview URLs. Finally, consider deploying web application firewalls (WAF) with custom rules to detect and block malicious SVG payloads.

Description

The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser. ContentReference properties, which could be used in the "Edit" section of the CMS, offered an upload functionality for documents. These documents could later be used as displayed content on the page. It was possible to upload SVG files that include malicious JavaScript code that would be executed if a user visited the direct URL of the preview image. Attackers needed at least the role "WebEditor" in order to exploit this issue. Affected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)

References

Community reviews

Loading reviews…